Icon

You are viewing the documentation of TeamCity 10.x and 2017.x, which is not the most recently released version of TeamCity.
View this page in the latest documentation or refer to the listing to choose the documentation corresponding to your TeamCity version.

 

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Note
  • NuGet build runners are supported on build agents running Windows OS by default.  Since TeamCity  Since TeamCity 2017.1 Linux and Mac OSX are supported when Mono is installed on the agent (NuGet command-line executable for Windows version 3.2 and later is strongly recommended with Mono).
  • NuGet build runners runners require an appropriate version on .NET Framework installed on the agent machine depending on the NuGet.exe version used: NuGet 2.8.6+ requires .NET 4.5+, earlier NuGet versions require .NET 4.0.
  • To use packages from an authenticated feed, see the NuGet Feed Credentials build feature.

...