Child pages
  • Build

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: Migrated to Confluence 4.0

Pre-requirements for .Net 4.0+ & VS 2010+:

  1. VS 2010/2012/2013 with latest SP. Warning: Newer versions of VS/.Net should not be installed on the machine.
  2. Disable UAC. (recomended)
  3. GIT Client (recommend GitExtention).
  4. Nemerle for .Net 4.0 & VS 2010 / .Net 4.5 & VS 2012 / .Net 4.5.1 & VS 2013 (http://nemerle.org/Downloads)

Get the code:

  1. Create a base folder for projects. For example: C:\NitraBase\
  2. If you want to build Nemerle from sources, clone Nemerle sources (git@github.com:rsdn/nemerle.git) into C:\NitraBase\Nemerle folder.
  3. Clone Nitra sources (git@github.com:rsdn/nemerle.git) into subfolder C:\NitraBase\Nitra\ or make Fork on https://github.com/JetBrains/Nitra, if you want to make changes in the project.

Build projects:

  1. Close all VS instances.
  2. Install latest Nemerle from http://nemerle.org/Downloads or build it from sources https://github.com/rsdn/nemerle by DevBuildQuick-4*.cmd. For example, run DevBuildQuick-VS2013.cmd for VS 2013 support.
  3. Enter into C:\NitraBase\Nitra\Nitra\ folder and run BuildBoot.cmd.

Using:

  1. Open the Nitra.sln solution and build it.
  2. If you want to use Nitra VS integration, you need to specify the path of Nitra folder in the NitraPath system environment variable. For example: NitraPath=C:\NitraBase\Nitra\

Debuging: Use the Nitra.Visualizer project to debug grammars.