Child pages
  • Getting Started with Plugin Development

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Item to check

Description

IntelliJ IDEA

IntelliJ IDEA version 9.0 or later, either Community Edition or Ultimate, must be installed on your computer.

Sources of IntelliJ IDEA Community Edition

The sources of IntelliJ IDEA Community Edition should be checked out to your local computer. This is not a requirement but will make it much easier for you to debug your plugins.
You can check out the sources either by using IntelliJ IDEA or from the command line. For detailed instructions, refer to Check Out & Build Community Edition.

IntelliJ IDEA SDK

Development of your plugins requires the IntelliJ IDEA SDK to be configured for your IDEA project. For more information, see Configuring IntelliJ IDEA SDK below.

Plugin DevKit

Please make sure that the "Plugin DevKit" plugin is enabled in Settings | Plugins.

Anchor
anchor2
anchor2

Configuring IntelliJ IDEA SDK

...