Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

  • IntelliJ IDEA 7.0 or higher (only Commercial licenses). (A License Server-compatible build of IntelliJ IDEA 6.0 is available upon request.)
  • ReSharper 3.1 or higher (only Commercial licenses).
  • dotTrace 5.5 or higher (only Commercial licenses). (Floating licenses are supported starting from dotTrace 3.1).
  • dotMemory 4.0 or higher (only Commercial licenses).
  • dotCover 1.0 or higher.
  • RubyMine 1.0 or higher.
  • PyCharm 1.0 or higher.
  • WebStorm 1.0 or higher
  • PhpStorm 1.0 or higher 
  • Tip

    You can have earlier versions of these products in your network, but you can't manage them using License Server.

    License Server issues and revokes license tickets to/from network clients based on properties of license keys that are provided by JetBrains after purchase. License Server supports two types of license keyslicensing models:
  • SinglePer-concurrent user license key that - allows a customer to access a product by a specific the number of concurrent users corresponding with the number of purchased license keys run by the License Server.Multi-user license key that
  • On-demandallows a customer to access a product by unlimited number of concurrent users pursuant to a separate license agreement with JetBrains. The agreement implies regular monitoring of the concurrent product usage and providing quarterly usage reports to JetBrains for the purpose of license "true-up".

If you have obtained a number of single-user license keys, you can download License Server and start using it right away, without requesting additional access permissions.

  • multiple users with a single license key run by the License Server. If you are interested in

...

  • the on-

...

  • demand license

...

...

  • the on-demand license terms.

System Requirements

  • Java SE Runtime Environment (JRE)/Java SE Development Kit (JDK) 6 or higher installed in any of the following operating systems:
    • Windows® (2000, NT 4.0 or higher, XP or Win7).
    • Linux/UNIX-based OS.
    • Macintosh OSX™.
  • Apache Tomcat 6.0.
  • Mozilla Firefox 2.0+, Internet Explorer 7.0+, Safari 3.0+ or Google Chrome for accessing the License Server control panel.

...